Back to overview
Resolved

Production Jobs Processing Delays

Jul 21, 2026 at 1:28pm UTC
Affected services
Production Jobs Health

Resolved
Jul 21, 2026 at 5:30pm UTC

On July 21, 2026, our background document-processing service was unavailable from approximately 6:28 AM to 10:30 AM PDT. During this window, newly uploaded documents were not processed and some in-progress uploads did not complete.
No customer data was lost — all previously stored documents and records remain intact. Our customer success team has reached out to every impacted customer, and affected documents have been reprocessed and/or resubmitted as needed, so everything should now be caught up. If you have any doubt about a specific upload, contact support and we'll confirm.
Root cause: our document processor hit a volume-limits issue. We've increased those limits to resolve it, and service was fully restored at 10:30 AM PDT. We're sorry for the disruption.

Created
Jul 21, 2026 at 1:28pm UTC

Our technical team is investigating reports of delayed document processing.